UT Classic and dual core CPUs

Discussion non-related
User avatar
[FnG] Marksman
Posts: 2273
Joined: Mon Aug 23, 2004 2:30 pm
Location: The Potteries, Midlands, UK
Contact:

UT Classic and dual core CPUs

Postby [FnG] Marksman » Thu Aug 26, 2010 11:39 am

Together with some mates I used to work with, I'm resurrecting a group that used to play UT '99 on the office PCs when we all worked in the same building (ah, those were the days...)

It used to be dead easy - we've got a network admin guy who sets up a dedicated server and the rest of us connect to it. Even now we're geographically strung out we can still do it from our computers at home. Awesome fun.

Anyway, I've got a new (budget) PC I've picked up (yay, I can start playing GW again!) - a low-end, but respectable, AMD dual-core system. It should be able to EASILY handle running UT '99, but in doing so I notice the CPU usage is constantly at 50%, which seems wrong. I've done some Googling and see that this is a common problem.

So far I've tried:
  • Adding FrameRateLimit=xx to UnrealTournament.ini
  • AMD's CPU optimizer utility (prob not necessary on Windows 7 but worth a stab)
  • Re-jigged binary launcher
  • Setting CPU Affinity to CPU0 only
  • VSync=True

I don't like that such a (nowadays) resource-lite game is occupying so much of the PC's power. I'm running Windows 7, with 4Gb RAM and an ATi Radeon HD 4850.

I've had a quick scan in the Unreal Tournament forums here and can't find any similar stories from FnG-ers. Has anyone encountered this, or got any ideas for possible fixes?
ImageImage

User avatar
[FnG] LcNessie
Site Admin
Posts: 5361
Joined: Sat May 07, 2005 11:44 am
Location: The Netherlands, Delfzijl
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] LcNessie » Thu Aug 26, 2010 12:30 pm

It appears to me that the 50% cap is because the game is single-threaded, so it can't make use of all the cores. Hence, 50% of your processing power remains unused.

I don't know if UT99 had mechanisms in place to limit CPU usage. I can imagine that the program just continues using all the cycles to render as much as possible, even if 90% of the renders is never used. Is the game itself running smoothly? (I sure hope so, with the hardware you mentioned... ;) )
With kind regards, Mathijs
Image
Image
WII: 8832 9602 6333 9837

[FnG] Mez
Posts: 90
Joined: Wed Nov 25, 2009 12:44 pm
Location: West Yorkshire, UK

Re: UT Classic and dual core CPUs

Postby [FnG] Mez » Thu Aug 26, 2010 1:16 pm

LcNessie is right - in Task Manager, use the menu option for "View...CPU History...One Graph Per CPU" and you should see that more clearly, for your dual-core CPU.

I'm a bit surprised that the active core is at 100% though. Try entering "stat fps" in the UT console to see if your frame rate is fixed at 60 (if that was possible in UT99, otherwise use the freeware FRAPS application). If it is 60 then VSync is probably on, as it should be to avoid run-away frame rates on that old game. If the FPS figure is absurdly high (> 100) then it isn't on for some reason.

You can try using the "ATI Catalyst Control Center" application (in Advanced Mode) to check your 3D settings, because under "All" there's a setting for "Wait for vertical refresh". This is the VSync option and you can set it to "Always ON" there. That might stop your graphics card going waaaay too fast :)

User avatar
[FnG] Marksman
Posts: 2273
Joined: Mon Aug 23, 2004 2:30 pm
Location: The Potteries, Midlands, UK
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] Marksman » Thu Aug 26, 2010 1:40 pm

Ah, good good good, this info makes some sense, thanks chaps. :)

Yes Nessie, the problem is indeed a silly, silly framerate which is resulting in hyperspeed (albeit hyper-smooth also) movement in-game. It's probably also going to be responsible for jumpiness in the netgame we're playing later today. I'm trying to find a way to put a cap on the rate at which the game is running because, as you say, the software of the game shouldn't be aware of the multiple cores and is clearly trying to use all resources in order to run AS FAST AS IT CAN (which, at the time of release, was more the problem!)

There's another possible fix which involves starting the game with a -CPUSPEED=xxxx switch. Could be worth a stab.

Thanks Mez, I'll try opening up the Control Center and checking the Wait for Vertical Refresh setting.

Cheers again, fellas. I'll let you know how it goes.
ImageImage

User avatar
[FnG] LcNessie
Site Admin
Posts: 5361
Joined: Sat May 07, 2005 11:44 am
Location: The Netherlands, Delfzijl
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] LcNessie » Thu Aug 26, 2010 3:29 pm

[FnG] Mez wrote:LcNessie is right - in Task Manager, use the menu option for "View...CPU History...One Graph Per CPU" and you should see that more clearly, for your dual-core CPU.


Actually, it's not that clear at all. It'll probably look as if the process is evenly distributed over both cores. However, this is probably because the CPU attempts to balance the load on the cores as much as possible. So, the thread runs on core 1, the controller logic sees that core 2 is watching the birds outside, so it swaps the load to core 2. Now core 2 is working hard and core 1 is twiddling thumbs, so the controller switches the thread back to core 1. Now core 1 ... blah blah, yaddah, and so forth and so on...

However, taskmanager doesn't have the resolution to display it in that detail, so what you actually see is an average. (At least, that's what I think is happening, unless you specify a core affinity, of course... )
With kind regards, Mathijs
Image
Image
WII: 8832 9602 6333 9837

[FnG] Mez
Posts: 90
Joined: Wed Nov 25, 2009 12:44 pm
Location: West Yorkshire, UK

Re: UT Classic and dual core CPUs

Postby [FnG] Mez » Fri Aug 27, 2010 2:40 pm

That's right, sure, it swaps them over to reduce heat stress on the chip. Ultimately, UT99 is single-threaded and will only be running on a single core at once. Ensuring VSync is on is the only way to try and reign in the mad framerate.

However the game's main loop might have been written to run as fast as possible, although though any coder with any sense would ensure that it regularly gave up some control. For example, when I run UT2004, I can see that one core uses 90% (main game) and another uses 10% (probably sound or networking) but the other cores are idle. It's just very difficult to write/test a game that has more than 2 main threads.

So, for gaming, I wish I'd bought a dual-core with a higher clock speed, rather than the slower quad-core that I got :(

Multi-cores are only good for transcoding video and ray-tracing, despite what Intel's marketing department might have us believe ;)

shadow_knight
Posts: 28
Joined: Sun Apr 11, 2004 1:22 am
Location: usa
Contact:

Re: UT Classic and dual core CPUs

Postby shadow_knight » Fri Oct 15, 2010 11:01 pm

ut is an old game dual cores run it to fast there is a fix for it that forces the game to run on one core only or you can start the game and set the affinity for the game to one core if you play on a server that runs the new ace anticheat you wont need it the program forces the game to one core hope this helps

User avatar
[FnG] Silke
Posts: 731
Joined: Wed Jan 07, 2004 10:31 pm
Location: Sweden
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] Silke » Tue Oct 26, 2010 7:22 pm

Hmm thats funny i have run UT on a quad core without any problem at all, so why does it have problem with dualcore ?

User avatar
[FnG] LcNessie
Site Admin
Posts: 5361
Joined: Sat May 07, 2005 11:44 am
Location: The Netherlands, Delfzijl
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] LcNessie » Wed Oct 27, 2010 1:31 pm

As I understand it, there's not a problem per sé, it's just using up all available CPU time, even though it's an old game and new(ish) hardware.
With kind regards, Mathijs
Image
Image
WII: 8832 9602 6333 9837

shadow_knight
Posts: 28
Joined: Sun Apr 11, 2004 1:22 am
Location: usa
Contact:

Re: UT Classic and dual core CPUs

Postby shadow_knight » Thu Oct 28, 2010 1:23 am

most of it has to do with what speed you are running the game reads it as to high and over speeds the game it was realy bad with laptops some of the comps use a program called cool and quite witch powers down your comp when not using alot of things so when you start your game up it see a low cpu speed till the program kicks in both cores cause you are now using them and the speed is increased thats when the game goes crazy altho i now of a few who have triple cores with win7 dont have the problem

User avatar
[FnG] Silke
Posts: 731
Joined: Wed Jan 07, 2004 10:31 pm
Location: Sweden
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] Silke » Mon Nov 01, 2010 4:56 pm

Have not yet tried it since i changed from WinXP to Win7 will see if i get time.
But now i know why i never have had any trouble with UT on my laptop, because i have turned all off the power management thingys to max. :rolleyes:

User avatar
[FnG] LcNessie
Site Admin
Posts: 5361
Joined: Sat May 07, 2005 11:44 am
Location: The Netherlands, Delfzijl
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] LcNessie » Mon Nov 01, 2010 10:01 pm

[FnG] Silke wrote:Have not yet tried it since i changed from WinXP to Win7 will see if i get time.
But now i know why i never have had any trouble with UT on my laptop, because i have turned all off the power management thingys to max. :rolleyes:


Yup, that'll work... :thumbup:
With kind regards, Mathijs
Image
Image
WII: 8832 9602 6333 9837

User avatar
[FnG] LcNessie
Site Admin
Posts: 5361
Joined: Sat May 07, 2005 11:44 am
Location: The Netherlands, Delfzijl
Contact:

Re: UT Classic and dual core CPUs

Postby [FnG] LcNessie » Fri Dec 24, 2010 3:22 pm

Seeing that this issue is a couple of months old already, it is slowly starting to dawn on me what the actual problem is.

It's not just "crazy framerates", but the game just plays way too fast, or isn't it?

This, indeed, has to do with all those power saving settings and clock throttling. Machine runs idle, clocks back, UT starts, finds a processor running on (for example) 600MHz, adjusts framerate for that, processor detects activity and clocks up, UT is not aware of this and something with a hand basket en route to hell.

Just turn off all your power saving options having to do with CPU/GPU throttling. Don't forget options in the bios...
With kind regards, Mathijs
Image
Image
WII: 8832 9602 6333 9837


Return to “Everything Else”

Who is online

Users browsing this forum: No registered users and 6 guests